Gentoo removendo o XMMS

Algumas coisas são dolorosas mas simplesmente tem que ser feitas.

Uma delas é acabar com tudo que use GTK+ 1. GTK+ 1 já era, não é mais mantido desde 2002. Não suporta Unicode, está cheio de bugs e a GTK+ 2 tem uma API muito melhor. Acontece que um famoso software chamado XMMS usa isso. Acontece também que o XMMS tem mais de 30 bugs não-resolvidos e bugs abertos desde 2001! Então faça-me o favor: Você gosta do XMMS? Eu também. Então vamos usar o Beep Media Player ou o Audacious. Ou o Listen, Amarok, Rythmbox, Banshee, Muine, qualquer coisa, temos zilhões de opções.

Então, o cara que mantém o XMMS no Gentoo decidiu largar o posto. Fiquei impressionado em saber que o cara fora do upstream mantinha o pacote e fazia modificações. Meus parabéns ao Luis Medinas. Também veja este outro post interessante sobre este assunto.

Uma solução razoável seria encorajar bastante a instalação de um pacote mais atual quando fosse feita uma instalação de pacotes obsoletos e não mantidos (ou colocar masked, mecanismo do Gentoo para indicar algo que você está fazendo algo por sua conta e risco). O Debian faz isso através de uma seção de pacotes obsoletos. Se bem que lá só tem coisas beeeeem obsoletas mesmo.

Faz tempo que eu não uso um Gentoo…

Abraços
Leandro Lameiro

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: